Wiki en construction / PBXware 7.0 - Incident concernant les services évolués en français

On se dépêche !

7.0 : Rapport de bug en langue française

Temps estimé :4 minutes

Statut – Mise à jour corrective prévue en v6.7.7 (fin décembre) & v7.1.0 (début février).

Contexte – Le déploiement de la dernière mise à jour PBXware 7.0 fait apparaître un bug de gravité modérée, spécifiquement en utilisant PBXware en Français. 

Détails L’accès ou l’ajout d’objets (exemple : BLFs, Horaires, …) dans les services évolués de PBXware est rendu impossible lorsque PBXware est utilisé en Français. Par ailleurs, si des paramètres ont existés précédant la mise à jour, ceux-ci seront invisibles en Français mais bien visibles en Anglais.

Nous vous invitons à ne pas enregistrer vos paramètres lorsque PBXware est en français sous peine de les voir disparaître.

Résolution

Un script a été spécifiquement élaboré pour résoudre ce bug.

Actuellement, le correctif ne peut être appliqué que sur des systèmes précédemment non patchés sur les versions suivantes :
– v6.7.6.0
– v7.0.0.0
– v7.1.0.0-beta

Voici les instructions à suivre afin de patcher votre système. 

  1. Connectez-vous en SSH au système.
  2. Téléchargez le fichier en exécutant la commande suivante : 
				
					wget https://downloads.bicomsystems.com/pbxware-support/patch-french-enhanced-services/patch-french-enhanced-services.sh
				
			

3. Accordez les permissions d’exécution avec la commande :

				
					chmod +x patch-french-enhanced-services.sh
				
			

4. Exécutez le patch en utilisant : 

				
					./patch-french-enhanced-services.sh
				
			

Lorsque vous exécutez le script, vous serez invité à saisir y ou Y à deux reprises pour appliquer le correctif.

				
					Version v7.0.0.0 with commit f305da8c available for patching. 
Do you want to continue? (y/n)

				
			

Entrez ainsi y.

				
					Next step will apply patch. Will replace by version v7.0.0.0 with 7158eded. 
Do you want to continue? (y/n)

				
			

Entrez de nouveau la lettre y.

En cas de problème, vous pouvez facilement restaurer la sauvegarde en utilisant le même script, mais avec l’option –restore-backup.

Après l’avoir exécuté, vous devriez être invité à choisir une sauvegarde disponible. De plus, vous pouvez également utiliser l’option –restore-backup-auto pour permettre au script de restaurer automatiquement une sauvegarde compatible du système.


Exemple :

				
					./patch-french-enhanced-services.sh --restore-backup
				
			
Partager

7.0 : Rapport de bug en langue française

Ou copiez le lien ci-dessous

CONTENU