NOTE : PBXware 7.2 - Bug d'affichage en langue française, nous vous conseillons d'attendre la résolution avant d'évoluer vers cette version.

Paré au décollage !

Configuration du réseau sous SERVERware

Temps estimé :8 minutes

Introduction

Sur cette page, vous obtiendrez des renseignements précis sur la conception du réseau pour SERVERware 4 basée sur deux approches différentes.

Dans un premier temps, vous obtiendrez une description du réseau SERVERware 4 sans prise en charge de la redondance au niveau du réseau.

La deuxième approche est la conception du réseau basée sur la redondance au niveau du réseau, ce qui permettra une haute disponibilité des services.

Pour obtenir des systèmes à haute disponibilité qui fourniront des services tolérants aux pannes avec un minimum ou aucune interruption de service, la planification de la conception du réseau doit être basée sur la redondance à tous les niveaux. Cela signifie que tous les composants réseau importants doivent être redondants. Ce document couvrira le niveau de commutation, disons jusqu’à la deuxième couche réseau. Le niveau de routage dépend de la conception du réseau mondial et peut être différent d’un cas à l’autre.

Cet exemple de conception du réseau est basé sur les commutateurs de la série Cisco WS-C3750G .
Ce commutateur de couche 3 prend en charge tous les protocoles et mécanismes requis pour la redondance.

Le commutateur Cisco WS-C3750G est capable de fournir les performances suivantes :

  • Structure de commutation 32 Gbit/s
  • Taux de transfert de pile de 38,7 mpps pour les paquets de 64 octets
  • Taux de transfert : 6,5 à 38,7 mpps selon le modèle

Nous suivrons également les fonctionnalités du commutateur que nous utiliserons pour obtenir la redondance du réseau :

  • La technologie Cisco CrossStack UplinkFast (CSUF) offre une redondance et une résilience réseau accrues grâce à une convergence Spanning Tree rapide.

  • (moins de 2 secondes) sur une pile de commutateurs avec la technologie Cisco StackWise.

  • La redondance maître 1:N permet à chaque membre de la pile de servir de maître, offrant ainsi la plus grande fiabilité de transfert.

  • Cross-Stack EtherChannel offre la possibilité de configurer la technologie Cisco EtherChannel sur différents membres de la pile pour une résilience élevée.

  • Le protocole RSTP (Rapid Spanning Tree Protocol) IEEE 802.1w fournit une convergence Spanning Tree rapide, indépendante des minuteries Spanning Tree et offre également l’avantage d’un traitement distribué.

  • Les unités empilées se comportent comme un seul nœud Spanning Tree.

  • Per-VLAN Rapid Spanning Tree (PVRST+) permet une reconvergence rapide du spanning-tree sur une base spanning-tree par VLAN, sans nécessiter la mise en œuvre d’instances de spanning-tree.

  • L’agrégation de bande passante jusqu’à 16 Gbit/s grâce à la technologie EtherChannel 10 Gigabit, 8 Gbit/s grâce à la technologie EtherChannel Gigabit et jusqu’à 800 Mbit/s grâce à la technologie Fast EtherChannel améliore la tolérance aux pannes et offre une bande passante agrégée plus rapide entre les commutateurs et vers les routeurs et les serveurs individuels.

Réseau non redondant

Le diagramme ci-dessus montre la configuration typique de SERVERware 4.

Le système est construit autour d’hôtes de stockage, d’hôtes de traitement et d’hôtes de sauvegarde. Deux hôtes de stockage configurés pour fonctionner en miroir assurent le stockage des hôtes de traitement sur SAN (Storage Array Network). Les hôtes de traitement s’exécutent localement sur les VPS fournis sur le réseau de stockage. Les VPS utilisent le réseau WAN pour fournir des services au client.

L’hôte de sauvegarde fournit de l’espace disque pour la sauvegarde des VPS. Les hôtes de sauvegarde utilisent le réseau de stockage pour transférer les données des hôtes de stockage vers l’espace disque de sauvegarde local.

En raison de la nature du trafic de stockage, nous devons séparer le trafic SAN des autres trafics sur le réseau. Dans le cas où nous avons beaucoup d’hôtes de traitement, la meilleure solution consiste à utiliser un commutateur réseau dédié qui serveur le trafic réseau. En réalité, nous utiliserons le même commutateur pour le SAN et tout autre trafic.
Dans ce cas, nous devons séparer le trafic en utilisant le concept VLAN. Ainsi, pour le trafic SAN, il sera créé SAN VLAN. Autre trafic que nous pouvons conserver dans le VLAN natif par défaut. En option, nous pouvons créer des VLAN pour le trafic vocal et configurer la priorité de ce trafic.

Le diagramme schématique suivant montre le réseau SERVERware 4 avec un commutateur Cisco (pas de redondance réseau) :

Pour séparer le trafic SAN des autres trafics sur le réseau, nous pouvons utiliser des VLAN et configurer tous les ports appartenant au réseau SAN pour qu’ils soient membres du SAN VLAN.

Voici un exemple de configuration Cisco qui montre comment configurer les VLAN sur les ports :

				
					...
interface GigabitEthernet0/0/1
switchport access vlan 20
switchport mode access
!
interface Vlan20
description “SAN VLAN”
no ip address
...
				
			

Réseau redondant

La conception du réseau SERVERware 4 avec redondance au niveau du réseau est basée sur deux commutateurs réseau connectés et configurés pour fonctionner en pile.

Le diagramme schématique de la redondance réseau SERVERware 4 est présenté sur l’image suivante :

Comme le montre le schéma ci-dessus, le réseau en redondance est basé sur deux commutateurs Cisco WS-3750G . Les commutateurs sont connectés en pile à l’aide de câbles d’empilage appropriés. Le bus d’empilage WS-3750G prend en charge 32 Gbit/s. Comme nous disposons de deux commutateurs, les hôtes doivent être connectés aux deux commutateurs. Cela signifie que pour chaque connexion (SAN, WAN), l’hôte doit disposer de deux interfaces Ethernet connectées aux deux commutateurs.

Cette conception de réseau permet une redondance au niveau du réseau. En cas de panne d’un commutateur, un autre commutateur prendra en charge le trafic réseau.

Le commutateur Cisco prend en charge EtherChannel sur les piles de commutateurs, ce qui est nécessaire et sans cela,
la redondance du réseau ne fonctionnera pas.

De la même manière que nous assurons la séparation du trafic SAN dans la conception de réseau non redondante, également dans la conception de réseau redondant, pour séparer le trafic SAN des autres trafics, nous configurerons les VLAN appropriés. Voici un exemple de configuration de commutateur Cisco avec redondance réseau et VLAN configurés pour séparer le trafic SAN :

 

				
					interface Port-channel5
switchport access vlan 20
switchport mode access
!
interface Port-channel6
switchport access vlan 20
switchport mode access
!
interface Port-channel7
switchport access vlan 20
switchport mode access
!
interface Port-channel8
switchport access vlan 20
switchport mode access
!
…
interface GigabitEthernet1/0/25
description Controller 1 SAN NIC
switchport access vlan 20
switchport mode access
channel-group 5 mode active
spanning-tree portfast
!
interface GigabitEthernet1/0/26
description Controller 2 SAN NIC
switchport access vlan 20
switchport mode access
channel-group 6 mode active
spanning-tree portfast
!
interface GigabitEthernet1/0/27
description Backup SAN NIC
switchport access vlan 20
switchport mode access
channel-group 7 mode active
spanning-tree portfast
!
interface GigabitEthernet1/0/28
description Proco SAN NIC
switchport access vlan 20
switchport mode access
channel-group 8 mode active
spanning-tree portfast
!
…
interface GigabitEthernet2/0/25
description Controller 1 SAN NIC down left
switchport access vlan 20
switchport mode access
channel-group 5 mode active
spanning-tree portfast
!
interface GigabitEthernet2/0/26
description Controller 2 SAN NIC down left
switchport access vlan 20
switchport mode access
channel-group 6 mode active
spanning-tree portfast
!
interface GigabitEthernet2/0/27
description Backup SAN NIC down left
switchport access vlan 20
switchport mode access
channel-group 7 mode active
spanning-tree portfast
!
interface GigabitEthernet2/0/28
description Proco SAN NIC down left
switchport access vlan 20
switchport mode access
channel-group 8 mode active
spanning-tree portfast
!
interface Vlan20
description "SAN VLAN”
no ip address
!
				
			

Dans l’exemple ci-dessus, deux interfaces Ethernet SAN du contrôleur 1 sont connectées au port Gigabit 25 du commutateur 1 et au port Gigabit 25 du commutateur 2. Ces deux ports sur le commutateur 1 et le commutateur 2 forment le port Ethernet Port-channel5. Sur ce port Ethernet est configuré le VLAN 20 qui est le VLAN pour le réseau SAN. Le contrôleur 2 est connecté au port gigabit 26 du commutateur 1 et au port gigabit 26 du commutateur 2. Ces deux ports du commutateur 1 et du commutateur 2 forment le port Etherchannel Port-channel6. Sur ce port Ethernet est configuré le VLAN 20 qui est le VLAN pour le réseau SAN. La même chose est configurée sur les hôtes de sauvegarde et de traitement. 

De cette manière est configurée la redondance au niveau du réseau.

Partager

Configuration du réseau sous SERVERware

Ou copiez le lien ci-dessous

CONTENU